top of page

Tec Startup Garage: BATCH 2 2021B

Public·74 members

Community Script Hook V .NET 3.0.2 For GTA 5


Hey guys, probably a dumb question but I've been out of modding since late 2015.Is it possible to load textures/images from your resource file from inside your script like it's possible with the GTA IV Scripthook? or do we still need to extract all the textures/images before we can access them?




Community Script Hook V .NET 3.0.2 For GTA 5



I tried this with net framework 4.6.2, with and without the ASP.NET, running as admin, with net framework 4.7.1, and finally with only scripthookv, asi loader, scripthookvdotnet and the scripts in the scripts folder and still no progress there. i have both version 12.0.30501 and 12.0.40660 x86 and x64 Visual C++ redist 2013, and Visual C++ redist 2015 version 14.0.24215 x86 and x64 What should i do to get the scripts to load? Thanks in advance.


Windows 10, Latest HookV, Native Trainer etc works perfect, so its finding the hook etc no issue. Ive reinstalled GTA and all mods etc, all scripts are latest and support my gta version, pressing F4 does bring the console etc up, but wont initialize any scripts at all.


AboutThis ASI plugin for the just released Script Hook V attempts to recreate this experience for GTAV. It's full source code is hosted on Github, development is community-driven and open to everybody, so contributions are warmly welcomed.Right now it's able to load, compile and run .NET scripts and reload them while the game is running (press the "Insert" key). Scripts are executed in a separate AppDomain, any exceptions thrown thus shouldn't affect the game or ScriptHook.The associated .NET scripting API is still in very early stages (kept close to the one from the GTAIV .NET ScriptHook, to simplify conversion) though, so you currently have to call some native functions manually through "GTA.Native.Function.Call".Thanks a lot to Alexander Blade for Script Hook V and HazardX for the inspiration with his GTAIV .NET ScriptHook.InstallationMake sure you have both the Microsoft .NET Framework 4.5 and the Microsoft Visual C++ Redistributable Package for Visual Studio 2013 (x64) installed (or loading will fail).Download and install Script Hook V (including the ASI loader).Download ScriptHookV .NET and copy the ASI into your game folder.Create (or download) a C#/VisualBasic code file (.cs, .vb) or compiled .NET assembly (.dll) inside a "/scripts/" subfolder in your game directory and start scripting!Official Website -vrel-community-script-hook-v-net/


Script Hook for the Community V.NET is an ASI plugin that permits in-game execution of scripts written in any.NET language. Its complete source code is available on Github (Changelog). Contributions are enthusiastically appreciated because development is community-driven and open to everyone.


Hello guys! Everything in my scripts folder is not working....But why?\nHere is my information:\nGame version: 1.0.1868.1\nScripthookV version: v1.0.1868.1\nScriptHookDotNet version: 3.0.3\nMy ScriptHookVDotNet log:\n[21:54:21] [DEBUG] Loading API from .\\ScriptHookVDotNet-univ2.dll ...\n[21:54:21] [DEBUG] Loading API from .\\ScriptHookVDotNet2.dll ...\n[21:54:21] [DEBUG] Loading API from .\\ScriptHookVDotNet3.dll ...\n[21:54:22] [DEBUG] Loading scripts from E:\\Neuer Ordner (3)\\steamapps\\common\\Grand Theft Auto V\\scripts ...\n[21:54:22] [DEBUG] Loading assembly BusSimulatorV.dll ...\n[21:54:22] [WARNING] Unable to resolve API version 2.10.12.\n[21:54:22] [WARNING] Unable to resolve API version 2.10.12.\n[21:54:22] [WARNING] Unable to resolve API version 2.10.12.\n[21:54:22] [WARNING] Unable to resolve API version 2.10.12.\n[21:54:22] [DEBUG] Loading assembly CoronerService.dll ...\n[21:54:22] [INFO] Found 1 script(s) in CoronerService.dll resolved to API 2.10.9.\n[21:54:22] [DEBUG] Loading assembly INMNativeUI.dll ...\n[21:54:22] [WARNING] Unable to resolve API version 2.10.12.\n[21:54:22] [WARNING] Unable to resolve API version 2.10.12.\n[21:54:22] [WARNING] Unable to resolve API version 2.10.12.\n[21:54:22] [WARNING] Unable to resolve API version 2.10.12.\n[21:54:22] [WARNING] Unable to resolve API version 2.10.12.\n[21:54:22] [WARNING] Unable to resolve API version 2.10.12.\n[21:54:22] [DEBUG] Loading assembly LSTransit.dll ...\n[21:54:22] [INFO] Found 1 script(s) in LSTransit.dll resolved to API 2.10.9.\n[21:54:22] [DEBUG] Loading assembly RouteCreator.dll ...\n[21:54:22] [WARNING] Unable to resolve API version 2.10.12.\n[21:54:22] [WARNING] Unable to resolve API version 2.10.12.\n[21:54:22] [WARNING] Unable to resolve API version 2.10.12.\n[21:54:23] [DEBUG] Instantiating script CoronerService ...\n[21:54:23] [ERROR] Failed to instantiate script CoronerService because constructor threw an exception: System.NullReferenceException: Object reference not set to an instance of an object.\nat GTA.ScriptDomain.ExecuteTask(IScriptTask task)\nat GTA.Native.Function.Call[T](UInt64 hash, InputArgument[] arguments)\nat GTA.Game.get_GameTime()\nat CoronerService..ctor()\n[21:54:23] [DEBUG] Instantiating script LSTransit.Main ...\n[21:54:23] [ERROR] Failed to instantiate script LSTransit.Main because constructor threw an exception: System.NullReferenceException: Object reference not set to an instance of an object.\nat GTA.ScriptDomain.LookupScriptFilename(Type scripttype)\nat GTA.Script..ctor()\nat LSTransit.Main..ctor()\nI'd appreciate the response.\nThanks!\n","tid":"28351","timestamp":"1586340405798","deleted":false,"editor":"uid":"175292","username":"ArtyGamer","userslug":"artygamer","upvotes":2,"uid":"175292","votes":2,"timestampISO":"2020-04-08T10:06:45.798Z","editedISO":"2020-04-09T16:16:47.683Z","index":0,"user":"uid":"175292","username":"ArtyGamer","fullname":"","userslug":"artygamer","reputation":"2","postcount":"1","picture":"","signature":"","banned":false,"status":"offline","lastonline":"1586459243896","groupTitle":null,"icon:text":"A","icon:bgColor":"#795548","lastonlineISO":"2020-04-09T19:07:23.896Z","custom_profile_info":[],"bookmarked":false,"upvoted":false,"downvoted":false,"selfPost":false,"display_edit_tools":false,"display_delete_tools":false,"display_moderator_tools":false,"display_move_tools":false,"display_post_menu":0},"timestamp":"1594343196977","deleted":false,"pid":"164053","content":"@ArtyGamer I will find a complete solution after 6 months....\nHere is the solution...\n\n","tid":"28351","toPid":"157405","uid":"158670","upvotes":0,"downvotes":0,"votes":0,"timestampISO":"2020-07-10T01:06:36.977Z","editedISO":"","index":1,"parent":"username":"ArtyGamer","user":"uid":"158670","username":"Mash Mixture","fullname":"","userslug":"mash-mixture","reputation":"0","postcount":"6","picture":"","signature":"","banned":false,"status":"offline","lastonline":"1594344920209","groupTitle":null,"icon:text":"M","icon:bgColor":"#607d8b","lastonlineISO":"2020-07-10T01:35:20.209Z","custom_profile_info":[],"editor":null,"bookmarked":false,"upvoted":false,"downvoted":false,"replies":"users":[],"timestampISO":"","count":0,"selfPost":false,"display_edit_tools":false,"display_delete_tools":false,"display_moderator_tools":false,"display_move_tools":false,"display_post_menu":0],"category":"slug":"10/installation-help-troubleshooting","bgColor":"#99dedb","parentCid":"0","link":"","description":"Get help installing a mod or troubleshooting bugs","color":"#fff","disabled":false,"imageClass":"cover","numRecentReplies":"1","icon":"fa-life-saver","post_count":"45674","order":"4","descriptionParsed":"Get help installing a mod or troubleshooting bugs\n","topic_count":"11706","class":"col-md-3 col-xs-6","cid":"10","name":"Installation Help & Troubleshooting","totalPostCount":"45674","totalTopicCount":"11706","thread_tools":["class":"toggleSolved alert-success topic-unsolved","title":"Mark as Solved","icon":"fa-check-circle","class":"toggleQuestionStatus","title":"Make this a normal topic","icon":"fa-comments"],"isFollowing":false,"isNotFollowing":true,"isIgnoring":false,"bookmark":null,"postSharing":[],"deleter":null,"deletedTimestampISO":"","related":[],"unreplied":false,"icons":[],"breadcrumbs":["text":"[[global:home]]","url":"/","text":"Installation Help & Troubleshooting","url":"/category/10/installation-help-troubleshooting","text":"My scripts are not working. Why?"],"privileges":"topics:reply":false,"topics:read":true,"topics:delete":false,"posts:edit":false,"posts:delete":false,"read":true,"view_thread_tools":false,"editable":false,"deletable":false,"view_deleted":false,"isAdminOrMod":false,"disabled":false,"tid":"28351","uid":0,"topicStaleDays":60,"reputation:disabled":false,"downvote:disabled":false,"feeds:disableRSS":true,"bookmarkThreshold":5,"postEditDuration":31540000,"postDeleteDuration":0,"scrollToMyPost":true,"rssFeedUrl":"/topic/28351.rss","pagination":"prev":"page":1,"active":false,"next":"page":1,"active":false,"rel":[],"pages":[],"currentPage":1,"pageCount":1,"loggedIn":false,"relative_path":"","template":"name":"topic","topic":true,"url":"/topic/28351/my-scripts-are-not-working-why","bodyClass":"page-topic page-topic-28351 page-topic-my-scripts-are-not-working-why"} Internal Error.Oops! Looks like something went wrong!Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.


About

Welcome to the group! You can connect with other members, ge...
Group Page: Groups_SingleGroup
bottom of page